You are not logged in.
Lost Password?


Register To Post



 Bottom   Previous Topic   Next Topic

#1
Vb not powering on
Posted on: 2013/7/31 8:11
Newbie
Joined 2013/7/31
2 Posts
Long Time User (6 Years)
So I just received my broken virtual boy after buying it on eBay. Long story short, it's stone dead. No signs of life. I get 6v from the battery pack, but nothing from pin 2 which should have 5v. I do get 5v from pin 6, not sure if that means anything. There's not much on the circuit board for the controller. Any ideas what the problem could be? Anybody else had this problem? Any help would be appreciated, thanks.
Top

#2
Re: Vb not powering on
Posted on: 2013/7/31 10:17
PVB Elite
Joined 2003/7/25
USA
1507 Posts
PVBCC 1stCoderContributor#3 PosterHOTY09 EntryLong Time User (15 Years) App CoderPVBCC 2010 EntryPVBCC 2013 Entry
Can you clarify what/where you're checking?

With 6 good batteries, you should get ~9V, not 6V. Also, the 5V is regulated inside the system, so if you're checking for 5V at the controller (unplugged from the system), you won't get it. You should get 9V (or whatever your actual battery voltage is) at pin 6, not 5V. If your voltage is that low, I'd replace your batteries, and/or check the contacts on and in the battery box, as well as on the controller.

Do you have a game in the system? It won't display anything without a game, though you will hear/feel a faint vibration of the mirrors moving inside (and you can see it if you look through the eyepieces... shining a flashlight in helps).

If you have it all connected, and your 5V is missing, it sounds like you have a dead regulator.

DogP
Top

#3
Re: Vb not powering on
Posted on: 2013/7/31 20:56
Newbie
Joined 2013/7/31
2 Posts
Long Time User (6 Years)
Alright, just tried it with fresh batteries (they weren't the best brand, but I got about 8v), game in, controller plugged in, and still no 5v at pin 2. No sign of life. The contacts in the battery box are clean, so I'm at a loss.
Top

 Top   Previous Topic   Next Topic


Register To Post