You are not logged in.
Lost Password?


Register To Post



 Bottom   Previous Topic   Next Topic

#1
Easy fix to glitchy display problem!
Posted on: 2009/9/12 23:23
Nintendoid!
Joined 2009/8/11
USA
112 Posts
Long Time User (10 Years)
--EDIT--

Here is a video of the repair process

http://www.youtube.com/watch?v=RQC4c9Lylg4

-- /EDIT --

I can't believe how easy it was to fix my Virtual Boy display problem! And the best part is, all you need is solder, solder wick, and a soldering iron!

Just a side note, if you don't already know, the FFC, or Flat Flexible Cable, is the thing that connects the main board of the VB to the display. I will use the FFC term a lot in this post, so it is good to know what the FFC is ahead of time!

Anyway, the back story is that I have been looking for a cheap and easy way to fix the display problem by only using basic tools (soldering iron, solder, solder wick) and easily obtainable and inexpensive parts. I didn't want to use chemicals, or an oven, or anything else along those lines. So I bought a handful of connectors, and tried a few methods unsuccessfully.

In my experimenting, I found that the film backing on the FFC was easy to melt. It melted so easy that it seemed like I could just solder the FFC, pretending that the film was not on the back of it. It was my hope that the solder would melt the backing of the FFC, and that the backing would not affect the solder joint at all, because hopefully the flux in the solder would help keep the connection clean.

So I did just that, and wouldn't you know, it worked!

The trick is that if you look at the display, you can see a strip of unmasked copper above the FFC and below the green soldermask. So I used this area to lay down some solder. Once I got a little ball of solder laid down, I used the solder in my hand to push the ball onto the top of the FFC (the soldering iron was used to keep the ball of solder flowing, and the ball always was partially touching the copper traces of the PCB). I never touched the iron to the FFC, because I didn't want to move the copper traces on the FFC. Anyway, I rolled the ball around for a while to melt the backing, and then I took out my soldering wick to clean up. To use the wick, I always pulled from the FFC to the display, making sure to go parallel with the traces.

The first time I tried, I pulled the soldering wick perpendicular a few times to clean up the big blob of solder I had, and this caused a few of the pins to shift. So fixing this board took a little longer, and a magnifying glass :\. But the second time, everything worked really well, and I was done within 3-5 minutes.

Then, the moment of truth. I reassembled the VB... and it worked!

If anyone is interested, I can make detailed instructions. I never saw this specific method on this website, but the only difference is that I am using solder to remove the backing rather than sand paper, or chemicals. The only real benefit of making a tutorial would be to have everything in one spot, along with soldering techniques (being many people have never done any fine pitch stuff, or have never used solder wick). So let me know if anyone would like to see a detailed tutorial.

Oh, and thanks DogP for your insight via PM!

-Matt
Edited by mbuchman on 2009/11/17 6:23
Top

#2
Re: Easy fix to glitchy display problem!
Posted on: 2009/9/13 0:03
Virtual Freak
Joined 2008/11/17
USA
77 Posts
Contributor10+ Game RatingsLong Time User (10 Years)
I would be interested in seeing a more detailed tutorial, some day I may have to try repairing my VB - the more instructions out there = the better.

It would also be great if you could do a video of the process. But I understand that might be asking a little much.

Whatever you do, there's already some great information in your post. Good work.
Top

#3
Re: Easy fix to glitchy display problem!
Posted on: 2009/9/15 7:35
PVB Elite
Joined 2003/7/25
USA
1507 Posts
PVBCC 1stCoderContributor#3 PosterHOTY09 EntryLong Time User (15 Years) App CoderPVBCC 2010 EntryPVBCC 2013 Entry
Cool... good to hear you were able to get a method that worked for you. The biggest problem I had with soldering directly without removing the coating first is that the solder didn't seem to stick to the copper well (which I think may be more because of the age of the copper, since even after manually removing the coating the solder doesn't stick that great until I remove the tarnish w/ the fiberglass pencil), and of course if you apply too much heat, the FFC will break at the bend where it's brittle. I thought it kinda made a mess too, but that's just aesthetics. But yeah, you should definitely post some pics and maybe some step by step instructions so people can compare the various methods.

DogP
Top

#4
Re: Easy fix to glitchy display problem!
Posted on: 2009/9/18 7:32
Nintendoid!
Joined 2009/8/11
USA
112 Posts
Long Time User (10 Years)
I was actually thinking of doing a video. It would show what I mean by rolling the ball of solder around and how to use the solder wick a lot better than pictures for some people who have never done that kind of stuff before.

I was also thinking of making a PDF in hopes it would last longer than a website that may fall off the face of the earth someday.

Hopefully in a week or so I can get something up.

Oh, and I just bought another Virtual Boy today, so I have plenty of displays to take videos and pictures of. I really have to stop checking ebay so much...
Top

#5
Re: Easy fix to glitchy display problem!
Posted on: 2009/11/17 6:22
Nintendoid!
Joined 2009/8/11
USA
112 Posts
Long Time User (10 Years)
I finally got around to posting a video. It is pretty basic, all I have is Windows Movie Maker, and I figured if I didn't post it now then I don't know when I would. So theoretically I can post a better video some other time but realistically I wont.

Here is the YouTube link.

http://www.youtube.com/watch?v=RQC4c9Lylg4

I don't see myself making a PDF like I originally said. The only thing I may add is instructions on taking apart the Virtual Boy to the beginning of the video (or maybe make that a second video).

I attached a high res picture of the finished solder joint. You can see some flux from the solder splattered onto the FFC and PCB, but other than that I think it looks pretty clean (but most importantly it works!)

Any comments are welcome, and if you have any suggestions for how I can improve the video / the video description on YouTube, then let me know!

-Matt

Attach file:



jpg  vbsolder_web.jpg (575.81 KB)
1146_4b0232d67b847.jpg 2537X1281 px
Top

#6
Re: Easy fix to glitchy display problem!
Posted on: 2009/11/17 6:57
PVB Elite
Joined 2003/7/26
USA
1465 Posts
PVBCC EntryCoderContributorSpecial AchievementTop10 PosterHOTY09 EntryLong Time User (15 Years) App Coder20+ Game RatingsPVBCC 2013 Entry
Pretty good video. Some kind of voice-over would have been nice, and it might have been a little closer to the action (although, if your camera can't focus that close, that's fine). I like the close-up, too. If that's the same camera that took the video, that's the viewpoint I would have used.

Also, I saw some flux bubbling there; did you apply that before the video, or was it just the core of the solder? I pre-fluxed, but it kind of made a mess (I don't have any no-clean flux or flux cleaner).

Your method uses a bit too much solder and braid for my tastes... I just tinned the tip of my iron really well and kind of gently scraped at the cable coating, and it worked fine (you have to scrape away from the cable like you did with the braid, though--learned that one the hard way! ). I didn't even have any bridges that I couldn't remove with a clean iron. I did kind of go overboard and probably took off too much of the cable, but I wanted a good connection and I reinforced the joint, anyway.

Once again, good job on the video.
Top

#7
Re: Easy fix to glitchy display problem!
Posted on: 2009/11/17 7:16
PVB Elite
Joined 2003/7/25
USA
1507 Posts
PVBCC 1stCoderContributor#3 PosterHOTY09 EntryLong Time User (15 Years) App CoderPVBCC 2010 EntryPVBCC 2013 Entry
Cool... thanks for posting that video. Couple quick questions... what temp is your iron set to? I was surprized to see with the amount of time the iron was on the cable that it didn't cause the cable to break at the bend (where the cable connects to the PCB). That was the problem I had when I tried that before. My display may have had more stress there than most, or I may have had my iron too hot though.

Also, what's the holder that you're holding the PCB with (model, where to buy, etc)? I keep thinking about getting one of them, but was never really sure if it'd be helpful... but that looks really useful. Heh, and I recognize that exact copper sponge... I love that thing :) .

Also, I may be wrong, but that desoldering wick looks like the cheap stuff from MCM (Tenma)... I've got some of that stuff, and if I could make a recommendation, it'd be to get some NTE stuff. I picked some of this up locally: http://www.microcenter.com/single_pro ... .phtml?product_id=0206736 , and I can't believe how much better that stuff works than the Tenma stuff. I always avoided wick because that Tenma stuff didn't work well, but I bought that NTE stuff when I needed some wick for work, and I was blown away how much better that stuff worked.

And yeah, that doesn't look too bad, although for comarison, here's a pic with the FFC eaten away w/ chemicals and then soldered... a little cleaner IMO, but of course more complicated, and if they both work equally well, then it doesn't really matter ;) :
Open in new window


DogP
Top

#8
Re: Easy fix to glitchy display problem!
Posted on: 2009/11/17 7:36
Nintendoid!
Joined 2009/8/11
USA
112 Posts
Long Time User (10 Years)
RunnerPack,

That is the best video I could get with my digital camera. I tried a few times but that's the best I could get. I was thinking of making a camera mount that I could attach to my vise, but this is probably the only thing I am ever going to record as far as soldering goes.

I used flux one time, but I found it did not really help, the flux already in the core of the solder is enough (plus I am pretty sure the desoldering braid has flux in it as well). And yeah, I used a lot of solder, so that is probably why I got the flux spots everywhere.

I thought about adding sound but I just didn't. Just didn't know what to say, and I figured if I waited until I came up with something, I would never upload the video.

The picture I have of the finished solder joint was actually done using a scanner. I put the part in a plastic bag, and then put it on my scanner.

Oh, and I don't have any more broken VBs, so I can't make any more videos.

You are probably right about using too much solder, using an inch or more of braid just to remove it is probably a good indicator I used too much solder, but eh, it worked.
Edited by mbuchman on 2009/11/17 7:49
Top

#9
Re: Easy fix to glitchy display problem!
Posted on: 2009/11/17 7:48
Nintendoid!
Joined 2009/8/11
USA
112 Posts
Long Time User (10 Years)
DogP,

Your one for sure came out cleaner, very nice!

I don't know what temp my iron is at. I could measure the wattage tomorrow.

The vise is from PanaVise. You can get them from DigiKey or Mouser. It is for sure not cheap, but they are really nice! You can buy it as individual components (a "head" and a "base") or as a complete set. You really have to look around to see what works best for you. Here is their website.

http://www.panavise.com/index.html?pa ... atarq=1&--SECTIONSword=ww

I bought the following and bolted it to my bench...
http://mouser.com/ProductDetail/Panav ... VJC7Vq%252bMl5yUj7teiF9pL
and
http://mouser.com/ProductDetail/Panav ... VJC7Vq%252bMl56tI9Ylj3utt

Oh, and the desoldering wick is from Radio Shack. I needed it quick for senior design, so that is what I ended up with. I will for sure have to look into the stuff you linked, I had a problem with my stuff when soldering a flash chip with a fine pitch.
Top

#10
Re: Easy fix to glitchy display problem!
Posted on: 2009/11/17 8:47
PVB Elite
Joined 2003/7/25
USA
1507 Posts
PVBCC 1stCoderContributor#3 PosterHOTY09 EntryLong Time User (15 Years) App CoderPVBCC 2010 EntryPVBCC 2013 Entry
Cool... thanks for that link... I'll have to order one of them next time I order parts.

DogP
Top

 Top   Previous Topic   Next Topic


Register To Post