You are not logged in.
Lost Password?


Register To Post



 Bottom   Previous Topic   Next Topic

#1
Dead display diagnosis
Posted on: 2/9 14:48
Newbie
Joined 1/13
1 Posts
I plugged in my virtual boy the other day after years of it sitting on my display shelf. Unfortunately, both displays were completely dead. I can hear the games, but there's no light coming from the displays at all.

Some googling led me to the ribbon cable defect and I found someone willing to solder my cables. He soldered the cables and tested them in his VB and said they worked perfectly. However, when I received them back, the problem remains. Sound, but absolutely nothing from the displays.

Other than the ribbon cables, are there any known problems that might be causing this behavior? Feel free to suggest easy stuff I might be overlooking. It's entirely possible that I'm an idiot :)

I'll gladly upload pictures or anything else if someone has any ideas.

Some extra information if it's helpful...

It's always possible the guy that did my repair is scamming me/didn't do a good job. But, he came recommended by several people and I don't think that's the case here.

I've tried the ribbon cables on both sides, so they have been removed and reinserted a few times.

I've turned the console on with the ribbon cables attached to the board but unscrewed from the console to see if the LEDs were producing light. They are not.

I don't know if it's relevant, but on the top of the main board (left side if you're looking at the displays), there's a black chip. When I turn the console on, this chip has a red light on it. That's probably normal, I've just never seen a chip like this, so it stands out to me.
Top

#2
Re: Dead display diagnosis
Posted on: 2/10 0:02
Nintendoid!
Joined 2017/10/29
USA
126 Posts
Long Time User (2 Years)
sent you a PM
Top

#3
Re: Dead display diagnosis
Posted on: Today 4:44
Newbie
Joined 2019/2/6
1 Posts
Long Time User (1 Year)
I wanted to see if you got this fixed. I picked up a cheap console and the displays are not working. I swapped a display from a working unit and nothing. When I had the broken console open I could see the mirrors did not move once the power was on. I can hear music but no video. It also appears that it is not recognizing controller inputs. Any suggestions?
Top

 Top   Previous Topic   Next Topic


Register To Post