You are not logged in.
Lost Password?


Register To Post



 Bottom   Previous Topic   Next Topic

#21
Re: gccVB, getting started . . .
Posted on: 2008/3/10 0:33
Nintendoid!
Joined 2007/8/8
Great Britain
201 Posts
CoderContributorHOTY09 EntryLong Time User (12 Years) App Coder
How to install gccVB 2007/03/26

Install Cygwin with with make, gcc, flex, patch, tar, gzip, autoconf, gperf, and bison. Extract vb_v810_gcc_03.tar.gz. In the cygwin bash shell run:

./make_v810.sh

. . .

Next, download and compile crt0.s like so:

v810-as -o crt0.o crt0.s

and copy crt0.o to cygwin/usr/local/v810/lib.

Finally, get the libgccvb headers from here.

. . .

How to use gccVB with Microsoft Visual Studio / Visual C++ Express Edition

Install MSYS. In Visual C++, in Tools/Options go to Projects and Solutions/VC++ Directories, and add msys/bin and cygwin/usr/local/bin.

Start a new Makefile Project. Enter name and location. Leave 'Create directory for solution' unchecked. Click OK.

In the next dialog enter:

Build command line:
make -f makefile.mak build 2>&1 | sed -e 's/\(.[a-zA-Z]\+\):\([0-9]\+\):/\1(\2):/'

Clean command line:
make -f makefile.mak clean



Refs: Tonc, devkitPro.

Attach file:


mak makefile.mak Size: 0.83 KB; Hits: 203
Edited by dasi on 2008/3/10 0:57
Edited by dasi on 2008/3/10 1:03
Edited by dasi on 2008/3/10 1:05
Edited by dasi on 2008/3/10 16:25
Edited by dasi on 2008/3/10 17:18
Edited by dasi on 2008/3/10 19:00
Edited by dasi on 2008/3/10 19:21
Top

#22
Re: gccVB, getting started . . .
Posted on: 2008/5/19 22:42
Nintendoid!
Joined 2007/12/14
169 Posts
CoderLong Time User (11 Years) App Coder
I had an issue building the latest gccvb using these steps which took me several hours to figure out so here's my solution in case anyone else runs into the same problem:

If you're like me, you may install Cygwin so that it uses DOS line endings instead of UNIX ones (I had it setup this way for a CS teaching asst. position I held at school). The problem with this is that the build process for binutils reads the CR character as part of the bfd_v810_arch definition, so you end up getting a linker error when building binutils complaining about an undefined reference to _bfd_v810_arch .

The solution to this, according to this page, is to run the following commands in the Cygwin bash shell before ./make_v810.sh :

set -o igncr
export SHELLOPTS

This sets up the environment to ignore the CR character, and allows binutils to build without error. If you setup Cygwin to use UNIX line endings (I think that's the default) then as far as I know these commands will have no effect, but I haven't tested that.

HTH. It sure took me a long time to figure this out.
Top

#23
Re: gccVB, getting started . . .
Posted on: 2008/7/1 16:39
Nintendoid!
Joined 2006/3/15
Ecuador
234 Posts
PVBCC 3rdCoderLong Time User (13 Years)
Hi guys, I was trying to incorporate metaprogramming to my engine to being able to use class inheritance and found the cause to the problem about gccvb complaining because of the '\' character in header files, it's not gcc fault's but Windows, since Microsoft alwasy like to do thing their on way, everytime you create a text file in windows it appends a special character to the end of each line, that character is interpreted as control character ^M by gnu progrmas, which makes gcc output an error.

There are some ways to solve this involving mounting the filesystem in some strange format, but here is an easier solution, I've attached a shell script which will take rid of those control characters in all your sources, you could make it being executed by your makefile before it compiles each source.

jorgeche

Attach file:


sh cleanFileFormat.sh Size: 0.15 KB; Hits: 175
Top

#24
Re: gccVB, getting started . . .
Posted on: 2008/7/2 10:47
Nintendoid!
Joined 2007/8/8
Great Britain
201 Posts
CoderContributorHOTY09 EntryLong Time User (12 Years) App Coder
Alternatively, in Visual C++, go to File / Advanced Save Options, set Line endings to Unix (LF), and click OK. Then save your file(s).
Top

#25
Re: gccVB, getting started . . .
Posted on: 2008/7/15 10:26
Administrator
Joined 2000/1/8
Germany
2515 Posts
Highscore Top10Highscore Top ScoreCoder#1 PosterHOTY09 1stLong Time User (15 Years) App Coder90+ Game Ratings
has anyone successfully built the new gccvb on vista yet? i am using a full cygwin installation and follow the guide, but keep getting the following error:

/bin/sh: line 5: C:gccvbbin: command not found
make: *** [all-libiberty]
Error 127 Error: building binutils
Top

#26
Re: gccVB, getting started . . .
Posted on: 2008/7/15 10:47
Nintendoid!
Joined 2007/12/14
169 Posts
CoderLong Time User (11 Years) App Coder
Quote:

KR155E wrote:
has anyone successfully installed the new gccvb on vista yet? i am using a full cygwin installation and follow the guide, but keep getting the following error:

/bin/sh: line 5: C:gccvbbin: command not found
make: *** [all-libiberty]
Error 127 Error: building binutils


I think Cygwin interprets the backslashes in "C:\gccvb\bin" as escape characters... I ran into this problem and changed the path to a UNIX-style "/c/gccvb/bin" -- note the use of forward slashes. This seemed to fix my build errors.

I also have MSYS installed which I think allows the C:\ = /c convention to work, so you might have to use /cygdrive/c instead.

HTH.
Top

#27
Re: gccVB, getting started . . .
Posted on: 2008/7/15 22:59
Administrator
Joined 2000/1/8
Germany
2515 Posts
Highscore Top10Highscore Top ScoreCoder#1 PosterHOTY09 1stLong Time User (15 Years) App Coder90+ Game Ratings
hey blitter, how did you actually change the path? i executed the script up to the point where i get the error, and used ultra edit to replace all occurences of "C:\gccvb\bin" with "/cygdrive/c/gccvb/bin", then continued, but still get the exact same error.
Top

#28
Re: gccVB, getting started . . .
Posted on: 2008/7/16 5:52
Nintendoid!
Joined 2007/12/14
169 Posts
CoderLong Time User (11 Years) App Coder
Quote:

KR155E wrote:
hey blitter, how did you actually change the path? i executed the script up to the point where i get the error, and used ultra edit to replace all occurences of "C:\gccvb\bin" with "/cygdrive/c/gccvb/bin", then continued, but still get the exact same error.


I have C:\cygwin\bin added to my PATH in Windows, as well as created a variable GCCVB that contains "/c/gccvb" -- you can change these variables by going to My Computer->Properties->Advanced->Environment Variables in XP.

I've built the toolchain in Vista once before and I believe the procedure is very similar. You shouldn't have to change anything in the tarball or the make_v810.sh script at all.
Top

#29
Re: gccVB, getting started . . .
Posted on: 2008/7/16 9:59
Administrator
Joined 2000/1/8
Germany
2515 Posts
Highscore Top10Highscore Top ScoreCoder#1 PosterHOTY09 1stLong Time User (15 Years) App Coder90+ Game Ratings
that helped, it seems to compile fine now. :) thanks a lot blitter!
Top

 Top   Previous Topic   Next Topic


Register To Post