You are not logged in.
Lost Password?


Register To Post



 Bottom   Previous Topic   Next Topic

#1
FlashBoy+ Stopped Working
Posted on: 2012/2/16 10:08
PVB Elite
Joined 2011/3/10
USA
899 Posts
Top10 PosterLong Time User (8 Years) 30+ Game Ratings
The last few times I tried to flash to my FB+ the percentage bar didn't get to 100%. I determined that it might be an issue with the USB connector, and after pushing in the USB cord with some firmness I was able to get complete flashes.

Now I have a second issue which just started tonight. After I get a complete flash I place the FB+ in my VB and nothing happens.

The VB is working just fine, all of my retail games and well as my two reproduction carts (Bound High and Space Pinball) are working without an issue. But the FB+ doesn't do anything, all I see is blackness.

At first I flashed a ROM and booted it up, played it for a few minutes and then swapped in Space Pinball. Then put the FB+ (with the same ROM) back into the VB and it didn't work. So it was working but now it no longer is.

I took the shell apart using my gamebit and took a look at everything. I do not see any obviously loose parts but then again I know nothing about soldering so I am probably overlooking any obvious issues.

I've tried a can of compressed air on the FB+ and the VB cartridge slot. All of my other games work perfectly and work the first time.

My FB+ is about a year old but I have only used it a handful of times. I've probably flashed it less than 20 times and it sat in my closet for most of last year with Wario Land on it. When I recently pulled out my VB the Wario Land save was still there and the FB+ was working just fine.

The USB and incomplete flashes only started to happen when I tried to flash the FB+ for the first time since the Wario Land flash, which was probably from March of 2011.

Nothing with my PC, USB, the cables, etc, has changed. Same set-up, same hardware, etc.

Does anyone have any suggestions?

Thanks!

edit::

Now I can't get it to be recognized by the PC, windows XP SP3. I tested the USB slot and the USB cable and they are working just fine, but when I plug in the FB+ it isn't recognized.

edit 2::

Every few attempts it seems to be recognized but then a split second later the FB software says "disconnected".

edit 3::

I just tried everything on a Windows 7 laptop, same issue. The FB+ isn't recognized. Tried 2 other USB cables, same problem. When Windows 7 sees something I get a "USB Device Not Recognized" message and then one about the driver software failed to install. But this only happens maybe 1 out of 20 times the FB+ is plugged in.

I find it hard to believe that it's the FB+, its pretty much brand new in regards to how infrequently I've found time to use it.
Edited by Lester Knight on 2012/2/16 10:23
Edited by Lester Knight on 2012/2/16 10:28
Edited by Lester Knight on 2012/2/16 10:29
Top

#2
Re: FlashBoy+ Stopped Working
Posted on: 2012/2/16 11:09
VUE(xpert)
Joined 2011/4/8
Great Britain
417 Posts
Long Time User (8 Years)
Just to check, did you pad the game you flashed?
I've had the same thing and then realised I forgot to pad the file out.
Top

#3
Re: FlashBoy+ Stopped Working
Posted on: 2012/2/16 11:26
PVB Elite
Joined 2011/3/10
USA
899 Posts
Top10 PosterLong Time User (8 Years) 30+ Game Ratings
Guess that is the 1 thing I left out of my post, the ROMs are properly padded.

At this point I can't even get the FB+ to be recognized by any of my machines. I'm not sure what happened, how it happened, or what to try next. It was working and then it wasn't. I'm wondering if a bad solder point would cause this issue, but then if it was only related to connection/flashing, what is making it not load on the VB? The ROM I last flashed (before making my post) worked, then after taking out the FB+ and putting it back in, I now only get a black screen.

By the way, my VB is powered with the US AC Adapter. So this isn't a battery issue or anything like that.

Right now everything is unresponsive. I don't even think I can do anything with it to further debug.
Top

#4
Re: FlashBoy+ Stopped Working
Posted on: 2012/2/16 14:35
PVB Elite
Joined 2011/4/27
USA
2288 Posts
Highscore Top10 1stHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreHighscore Top ScoreCollection Top10Contributor#2 PosterLong Time User (8 Years) 30+ Game Ratings
I would definitely e-mail Richard Hutchinson directly about this issue. If it is a problem with the FlashBoy+ itself, I'm sure that he'll be willing to help fix it for you.

Also, if the problem is determined and resolved, it would be good to post the details on here, so that others who own FlashBoy+s will know what possibly to watch for in the future.
Top

#5
Re: FlashBoy+ Stopped Working
Posted on: 2012/2/16 19:45
VUE(xpert)
Joined 2007/7/28
Great Britain
336 Posts
Long Time User (12 Years) App Coder
I don't understand why folk don't contact me direct. I will gladly sort out any repairs etc.
Top

#6
Re: FlashBoy+ Stopped Working
Posted on: 2012/2/16 22:06
PVB Elite
Joined 2011/3/10
USA
899 Posts
Top10 PosterLong Time User (8 Years) 30+ Game Ratings
My apologies to you. When I first started to debug last night I thought perhaps it was a computer issue on my end. After all, the cart is basically brand new, I thought it was impossible that it could be a problem with the FB+.

Instead of going to bed, like I should have, I sat up and tried everything I could think of. By the time I was done I came to the conclusion that directly contacting you the next day would have been a better solution!
Top

#7
Re: FlashBoy+ Stopped Working
Posted on: 2012/2/23 19:53
VUE(xpert)
Joined 2007/7/28
Great Britain
336 Posts
Long Time User (12 Years) App Coder
I got the cart today. Tested it, and it's working fine here.
Top

#8
Re: FlashBoy+ Stopped Working
Posted on: 2012/7/12 22:08
PVB Elite
Joined 2011/3/10
USA
899 Posts
Top10 PosterLong Time User (8 Years) 30+ Game Ratings
i should have written this reply much sooner, i apologize for that.

richard ended up replacing the usb connector, just in case that was the issue. he kept me informed during each step of the process. i received the cart back and flashed a bunch of things to it without issue.

thanks mate! =)
Top

 Top   Previous Topic   Next Topic


Register To Post