You are not logged in.
Lost Password?


Register To Post



 Bottom   Previous Topic   Next Topic

#1
Help!
Posted on: 9/4 15:41
Newbie
Joined 2016/10/6
7 Posts
Hi all,
So I've had a broken virtual boy for just over 8 months now. It worked fine for the first day, but after that, it was completely buggered. Both eye peices have scanlines, and occasionaly the right eye doesn't work at all! Now, I have tried resoldering the ribbon cables, but that didn't work, so
I'm left with only one solution: put them in the oven.

Have any of you tried this method? Have any of you ended up with broken leds because of this? Or is it actually foolproof? I would love to get this fixed, as it has been shipped from the other side of the earth, so I can't really get a refund.
Thanks!
Top

#2
Re: Help!
Posted on: 9/4 17:26
PVB Elite
Joined 2009/12/30
Netherlands
505 Posts
Highscore Top10Highscore Top ScoreContributor10+ Game RatingsLong Time User (7 Years)
Oven trick will not work after you have soldered them. If they do not work after soldering, there might be a few things that could be the root of the issue.

It could be that soldering it didn't get a warm enough temperature for the traces to really attach to the board, you could solve that by pushing down on a desoldering wick with your soldering iron.

It could be that both have a cracked trace in the cable.

It could be that the end part of the cable (that goes into the socket of the mainboard of the VB) has issues, check that, pull it out a bit, clean the connectors and see if that does something.

I do think the problem is that you didn't get a correct soldering job on them since they both show the same issue (highly unlikely that they both have other issues than the standard one). Can you make a picture of it and post it here maybe?
Top

#3
Re: Help!
Posted on: 9/4 19:05
VUE(xpert)
Joined 2012/12/4
322 Posts
CoderLong Time User (4 Years)
Never bake your Virtual Boy displays, as it will not correct the problem. It's one of those urban legends like bats having poor eyesight or Albert Einstein saying something about trying the same thing over and over.

The means by which the ribbon was originally attached to the display boards was with a silicone adhesive that was chemically cured. In the unlikely event you could reactivate this chemical process by getting it hot enough, the natural temperature resistance of silicone means you'd have to get it well above the temperature required to melt the plastic enclosure and components on the circuit board.

The oven method will not solve the problem, but can give you a new problem by permanently damaging the display. I need to get in touch with Krisse to get a PSA about this pinned on the forum...

Unless you're handy with adhesives yourself, your best bet to correct the problem is either going to be to have the ribbon stripped of its protective coating and soldered directly to the display board, or remove the cable entirely and wire the display board directly to the motherboard.
Top

#4
Re: Help!
Posted on: 9/4 19:19
Newbie
Joined 2016/10/6
7 Posts
Damn... glad I didn't try that then!
I'm not handy enough with adhesives for that. I might just try to hunt down a new pair of leds if that's possible. Man, what a bummer. Thanks for your help!
Top

#5
Re: Help!
Posted on: 9/4 19:39
VB Gamer
Joined 6/24
USA
30 Posts
Try taking to (PM) bennybtl

http://www.planetvb.com/modules/newbb ... t_id=38023#forumpost38023
Top

#6
Re: Help!
Posted on: 9/9 15:14
Nintendoid!
Joined 2012/10/16
191 Posts
Long Time User (4 Years)
Um... The oven trick does work. I have two non-soldered VBs to prove it. So, I wouldn't flat out say that. I would not do the oven trick unless you've done your research though. And yes you already did the solder method, which means you probably didn't do it right, I'm sorry to say. Typically it's oven trick first, then solder. Or solder first by someone on here.
Top

#7
Re: Help!
Posted on: 9/9 17:40
VUE(xpert)
Joined 2012/12/4
322 Posts
CoderLong Time User (4 Years)
The oven trick makes no changes to the structure or adhesive of the connection in question. If it worked for you, then I'd put all my eggs in the "it's only a matter of time" basket.

Besides, if it did work consistently, people would be doing that instead of finding people to solder the displays for them. An isolated incident of it apparently working isn't a strong enough data point for me to retract my warning.
Top

#8
Re: Help!
Posted on: 9/9 18:03
VB Gamer
Joined 6/24
USA
30 Posts
I performed the oven trick twice on my original unit. Both times it only lasted about a month and I ultimately created additional damage to the ribbon cables.
Top

#9
Re: Help!
Posted on: 9/13 18:24
Newbie
Joined 9/11
6 Posts
I do the oven trick for years ago and it helped for abaout a half year. After that i test it with a breackfast knife, make it hot enough and strafe softliy over the it. After it was realy hot on this place i turned the display und pressed it with the ribbon cable on a glass table so that it becomes co÷d and will be pressed on again. After that i strafed softly again with my nail between the smal cables where its glued on the display.

That takes abaout 15min of time, makes it a lot hotter then the oven trick but only on that place you need it and work for me for over a year now. And if the scanlines come again i will do it again so long it worked with that because how i said, it takes only abaout 15mins time :)

But how the other said, it can only work if you dosent solder it bevore.. after soldering it worng only soldering right again can help.
Top

 Top   Previous Topic   Next Topic


Register To Post